Жизнь

Установка RVM в Linux

Установка RVM в Linux



We are searching data for your request:

Forums and discussions:
Manuals and reference books:
Data from registers:
Wait the end of the search in all databases.
Upon completion, a link will appear to access the found materials.

01 из 06

Введение

Настройка среды Linux для RVM - самая сложная часть установки самого RVM. Если вы не знакомы с процессом компиляции Ruby из исходного кода, вы можете немного потеряться. К счастью, такие дистрибутивы, как Ubuntu, упрощают работу.

Эти инструкции написаны на Ubuntu. По большей части они будут применяться к любому дистрибутиву на основе Debian или Ubuntu. Для других дистрибутивов имена пакетов могут отличаться, но те же библиотеки и такие должны быть установлены.

02 из 06

Установите GCC и другие инструменты

Прежде всего вам нужен компилятор C и утилита Make. Они обычно связаны вместе с некоторыми другими инструментами и за кулисами магии в пакете под названием наращивание важно, Так что это первый пакет, который должен быть установлен.

$ sudo apt-get install build-essential

Кроме того, RVM также потребуется curl для загрузки файлов. Это также просто apt-get.

$ sudo apt-get install curl
03 из 06

Установить библиотеки разработки

Далее вам понадобятся несколько библиотек и их аналоги из пакета разработки. Две из этих библиотек - readline, которая позволяет редактировать строки текста в bash или IRB, и zlib, которые Rubygems должен будет функционировать. Также включены OpenSSL и LibXML.

$ sudo apt-get установить zlib1g-dev libreadline-dev libssl-dev libxml2-dev
04 из 06

Установить RVM

Теперь, когда все настроено, установите сам RVM. Это делается с помощью сценария оболочки, который вы можете загрузить и запустить напрямую с помощью одной команды.

$ bash -s стабильный

Добавьте следующую строку к вашему ~ / .Bashrc файл.

-s "$ HOME / .rvm / scripts / rvm" &&. "$ HOME / .rvm / scripts / rvm" # Это загружает RVM

Затем перезагрузите среду bash (или закройте окно терминала и откройте новое).

$ source ~ / .bashrc05 из 06

Подробнее о требованиях

В более поздних версиях RVM Требования к RVM Команда была добавлена, чтобы дать вам больше информации о требованиях сборки и запуска для различных рубинов. Вы можете просмотреть и просмотреть этот список требований, запустив Требования к RVM.

$ rvm требования

Это даже дает вам удобный кв-прибудете Команды, которые вы можете просто скопировать и вставить.

06 из 06

Установить рубин

Возможно, вы захотите установить интерпретатор MRI Ruby (официальный интерпретатор Ruby, с которым вы, вероятно, уже знакомы). Чтобы сделать это (после того, как вы установили зависимости сборки, см. Предыдущие шаги), это просто рвм установить 1.9.3, Это даст вам интерпретатор MRI версии 1.9.3 (стабильный выпуск на момент написания этой статьи) на последнем уровне исправлений.

$ rvm установить 1.9.3

Вот и все. Запомни рвм использовать 1.9.3 прежде чем вы начнете использовать Ruby и все, Ruby установлен.


Смотреть видео: Ruby on Rails в Ubuntu Linux rvm, ruby, heroku (August 2022).